FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.
The treats are interesting for many reasons:
The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?
The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input
Line 1: A single integer, N
Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output
Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
5
1
3
1
5
2
Sample Output
43
题目大意:
//区间dp
//给定一个数组,每次只能从首或位取一个数,每个数的权值为取该数的序数,求所能使所有数乘上他的权值的和值最大,并求出该最大和值。
思路:
//dp[i][j]表示区间[i,j]的最大值
//逆推,每次往上添加一个数字(初始为1个) 直到长度为N
//那么dp[i,j]一定由dpi+1,j或
// dpi,j-1中的最大值得来
//则状态转移方程
//dp[i][j]=max(dp[i+1][j]+A[i](N-(j-i)),dp[i][j-1]+A[j](N-(j-i)));
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX= 2005;
int A[MAX],dp[MAX][MAX];
//区间dp
int main(void){
int N;
while(cin>>N){
memset (dp,0,sizeof(dp));
for(int i=1 ; i<=N ; i++){
cin>>A[i];
}
//N-(j-i)--->表示这个数是第几个取得
for(int i=N ; i>=1 ; i--){//要逆推从底向上
for(int j=i ; j<=N ; j++){
dp[i][j]=max(dp[i+1][j]+A[i]*(N-(j-i)),dp[i][j-1]+A[j]*(N-(j-i)));
}
}
//区间1~N的最大和
cout<<dp[1][N]<<endl;
}
return 0;
}