A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
题目大意:给出两个序列,求出最长子序列的长度并输出(序列不一定连续)
思路:
//dp[i][j]为 第一个串A到i位置与第二个串B到j位置的最长公共子序列
//则状态转移方程可描述为:
//if(A[i]==B[j]) dp[i][j]==dp[i-1][j-1];
//else dp[i][j]=max(d[i-1][j],dp[i][j-1]);
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=1000;
char A[MAX],B[MAX];
int dp[MAX][MAX];
int main(void){
while(scanf("%s %s",A+1,B+1) != EOF){
int lenA=strlen(A+1);
int lenB=strlen(B+1);
dp[0][0]=0;
for(int i=1 ; i<=lenA ; i++){
for(int j=1 ; j<=lenB ; j++){
if(A[i] == B[j]){
dp[i][j] = dp[i-1][j-1]+1;
}else{
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
}
}
cout<<dp[lenA][lenB]<<endl;
}
return 0;
}