Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
Sample Input
2
2
20 25
40
1
8
Sample Output
08:00:40 am
08:00:08 am
题意:一个人可以单独买票花费一定的时间,也可以两个人一起买票,也给定一个时间,
给出K个人的单独买票时间和K-1个相邻的两个人一起买票的时间,问一共花费的最小时间。
思路:
第i个人买票分为两种情况,一是个人票,二是组合票,
状态转移方程为: dp[i]=min(dp[i-1]+A[i],dp[i-2] + B[i])
dp[i]为i个人买票的最短时间
#include<iostream>
#include<cstring>
#include<stdio.h>
#include<queue>
using namespace std;
const int MAX=2005;
int dp[MAX],N,n;
int A[MAX];//个人票时
int B[MAX];//组合票时
int main(void){
cin>>N;
while(N--){
cin>>n;
for(int i=1 ; i<=n ; i++){
cin>>A[i];
}
for(int i=2 ; i<=n ; i++){
cin>>B[i];
}
dp[1]=A[1];
for(int i=2 ; i<=n ; i++){
dp[i]=min(dp[i-1]+A[i],dp[i-2]+B[i]);
}
int h=dp[n]/3600+8;
int m=dp[n]/60%60;
int s=dp[n]%60;
if(h<12){
printf( "%02d:%02d:%02d am\n",h,m,s );
}else if(h==12){
printf( "%02d:%02d:%02d pm\n",h,m,s );
}else{
printf( "%02d:%02d:%02d pm\n",h,m,s );
}
}
return 0;
}