Define the function S(x)S(x) for xx is a positive integer. S(x)S(x) equals to the sum of all digit of the decimal expression of xx. Please find a positive integer kk that S(k*x)\%233=0S(k∗x)%233=0.
Input Format
First line an integer TT, indicates the number of test cases (T \le 100T≤100). Then Each line has a single integer x(1 \le x \le 1000000)x(1≤x≤1000000) indicates i-th test case.
Output Format
For each test case, print an integer in a single line indicates the answer. The length of the answer should not exceed 20002000. If there are more than one answer, output anyone is ok.
样例输入
1
1
样例输出
89999999999999999999999999
9乘以任何数和都为9
所以直接输出233个9就好
#include <iostream>
#include <string>
#include <cstdio>
using namespace std;
int main()
{
int T;
int x;
scanf("%d",&T);
while(T--)
{
scanf("%d",&x);
for(int i=1;i<=233;i++)
printf("9");
printf("\n");
}
return 0;
}