第一类Stirling数 s(p,k)
s(p,k)的一个的组合学解释是:将p个物体排成k个非空循环排列的方法数。
s(p,k)的递推公式: s(p,k)=(p-1)*s(p-1,k)+s(p-1,k-1) ,1<=k<=p-1
边界条件:s(p,0)=0 ,p>=1 s(p,p)=1 ,p>=0
递推关系的说明:
考虑第p个物品,p可以单独构成一个非空循环排列,这样前p-1种物品构成k-1个非空循环排列,方法数为s(p-1,k-1);
也可以前p-1种物品构成k个非空循环排列,而第p个物品插入第i个物品的左边,这有(p-1)*s(p-1,k)种方法。
第二类Stirling数 S(p,k)
S(p,k)的一个组合学解释是:将p个物体划分成k个非空的不可辨别的(可以理解为盒子没有编号)集合的方法数。
k!S(p,k)是把p个人分进k间有差别(如:被标有房号)的房间(无空房)的方法数。
S(p,k)的递推公式是:S(p,k)=k*S(p-1,k)+S(p-1,k-1) ,1<= k<=p-1
边界条件:S(p,p)=1 ,p>=0 S(p,0)=0 ,p>=1
递推关系的说明:
考虑第p个物品,p可以单独构成一个非空集合,此时前p-1个物品构成k-1个非空的不可辨别的集合,方法数为S(p-1,k-1);
也可以前p-1种物品构成k个非空的不可辨别的集合,第p个物品放入任意一个中,这样有k*S(p-1,k)种方法。
第一类斯特林数和第二类斯特林数有相同的初始条件,但递推关系不同。
第一类斯特林数
A murder happened in the hotel. As the best detective in the town, you should examine all the N rooms of the hotel immediately. However, all the doors of the rooms are locked, and the keys are just locked in the rooms, what a trap! You know that there is exactly one key in each room, and all the possible distributions are of equal possibility. For example, if N = 3, there are 6 possible distributions, the possibility of each is 1/6. For convenience, we number the rooms from 1 to N, and the key for Room 1 is numbered Key 1, the key for Room 2 is Key 2, etc.
To examine all the rooms, you have to destroy some doors by force. But you don’t want to destroy too many, so you take the following strategy: At first, you have no keys in hand, so you randomly destroy a locked door, get into the room, examine it and fetch the key in it. Then maybe you can open another room with the new key, examine it and get the second key. Repeat this until you can’t open any new rooms. If there are still rooms un-examined, you have to randomly pick another unopened door to destroy by force, then repeat the procedure above, until all the rooms are examined.
Now you are only allowed to destroy at most K doors by force. What’s more, there lives a Very Important Person in Room 1. You are not allowed to destroy the doors of Room 1, that is, the only way to examine Room 1 is opening it with the corresponding key. You want to know what is the possibility of that you can examine all the rooms finally.
Input
The first line of the input contains an integer T (T ≤ 200), indicating the number of test cases. Then T cases follow. Each case contains a line with two numbers N and K. (1 < N ≤ 20, 1 ≤ K < N)
Output
Output one line for each case, indicating the corresponding possibility. Four digits after decimal point are preserved by rounding.
Sample Input
3
3 1
3 2
4 2
Sample Output
0.3333
0.6667
0.6250
Hint
Sample Explanation
When N = 3, there are 6 possible distributions of keys:
Room 1 Room 2 Room 3 Destroy Times
1 Key 1 Key 2 Key 3 Impossible
2 Key 1 Key 3 Key 2 Impossible
3 Key 2 Key 1 Key 3 Two
4 Key 3 Key 2 Key 1 Two
5 Key 2 Key 3 Key 1 One
6 Key 3 Key 1 Key 2 One
In the first two distributions, because Key 1 is locked in Room 1 itself and you can’t destroy Room 1, it is impossible to open Room 1.
In the third and forth distributions, you have to destroy Room 2 and 3 both. In the last two distributions, you only need to destroy one of Room 2 or Room
主要算法:求n个数组成k个环个数
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<queue>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<iomanip>
using namespace std;
typedef long long ll;
const int MOD = 1000;
ll fac[21]={1};
ll stir1[21][21];
void init()
{
for(int i=1;i<21;i++)
fac[i]=fac[i-1]*i;
for(int i=1;i<=20;i++){
stir1[i][0]=0;
stir1[i][i]=1;
for(int j=1;j<i;j++)
stir1[i][j]=stir1[i-1][j-1]+(i-1)*stir1[i-1][j];
}
}
int T;
int main() {
ios_base::sync_with_stdio(false);
// freopen("data.txt","r",stdin);
cin >> T;
init();
int n,k;
while(T--)
{
cin >> n >> k;
if(n==1 || k==0)
{
cout<<"0.0000"<<endl;
continue;
}
double re = 0;
for(int i=1;i<=k;i++)
{
re += stir1[n][i] - stir1[n-1][i-1];
}
re /= fac[n];
cout.setf(ios::fixed);
cout<< setprecision(4) << re <<endl;
}
return 0;
}
B - Count the Buildings
There are N buildings standing in a straight line in the City, numbered from 1 to N. The heights of all the buildings are distinct and between 1 and N. You can see F buildings when you standing in front of the first building and looking forward, and B buildings when you are behind the last building and looking backward. A building can be seen if the building is higher than any building between you and it.
Now, given N, F, B, your task is to figure out how many ways all the buildings can be.
Input
First line of the input is a single integer T (T<=100000), indicating there are T test cases followed.
Next T lines, each line consists of three integer N, F, B, (0<N, F, B<=2000) described above.
Output
For each case, you should output the number of ways mod 1000000007(1e9+7).
Sample Input
2
3 2 2
3 2 1
Sample Output
2
1
解题思路:ans = stir1[n-1][f+b-2] * C[f+b-2][f-1];
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<queue>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<iomanip>
using namespace std;
typedef long long ll;
const int MOD = 1000000007;
const int N = 2005;
//ll fac[N]={1};
ll stir1[N][N];
ll C[N][N];
void init()
{
// for(int i=1;i<N;i++)
// fac[i]=fac[i-1]*i;
for(int i=1;i<N;i++){
stir1[i][0]=0;
stir1[i][i]=1;
for(int j=1;j<i;j++)
stir1[i][j]= ( stir1[i-1][j-1] + ( ((i-1) % MOD) * (stir1[i-1][j] % MOD) )%MOD )%MOD;
}
C[1][0] = C[1][1] = 1;
for (int i = 2; i < N; i++){
C[i][0] = 1;
for (int j = 1; j < N; j++)
C[i][j] = (C[i - 1][j] + C[i - 1][j - 1])%MOD;
}
}
int T;
int main() {
// ios_base::sync_with_stdio(false);
// freopen("data.txt","r",stdin);
init();
int n,f,b;
scanf("%d",&T);
while(T--)
{
scanf("%d%d%d",&n,&f,&b);
if(f+b-2>n-1)
{
cout<<0<<endl;
continue;
}
//ans = stir1[n-1][f+b-2] * C[f+b-2][f-1];
cout<< ( (stir1[n-1][f+b-2]%MOD) * (C[f+b-2][f-1]%MOD) )%MOD<<endl;
}
return 0;
}
第二类斯特林数
Recently in Teddy's hometown there is a competition named "Cow Year Blow Cow".N competitors had took part in this competition.The competition was so intense that the rank was changing and changing.
Now the question is:
How many different ways that n competitors can rank in a competition, allowing for the possibility of ties.
as the answer will be very large,you can just output the answer MOD 20090126.
Here are the ways when N = 2:
P1 < P2
P2 < P1
P1 = P2
Input
The first line will contain a T,then T cases followed.
each case only contain one integer N (N <= 100),indicating the number of people.
Output
One integer pey line represent the answer MOD 20090126.
Sample Input
2
2
3
Sample Output
3
13
解题主要算法:把n个数放到k个盒子中
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<queue>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<iomanip>
using namespace std;
typedef long long ll;
const int MOD = 20090126;
const int N = 105;
ll fac[N]={1};
//ll stir1[N][N];
ll stir2[N][N];
//ll C[N][N];
void init()
{
for(int i=1;i<N;i++)
fac[i]= ( (fac[i-1]%MOD) * (i%MOD) )%MOD;
// for(int i=1;i<N;i++){
// stir1[i][0]=0;
// stir1[i][i]=1;
// for(int j=1;j<i;j++)
// stir1[i][j]= ( stir1[i-1][j-1] + ( ((i-1) % MOD) * (stir1[i-1][j] % MOD) )%MOD )%MOD;
// }
for(int i=1;i<N;i++){
stir2[i][0]=0;
stir2[i][i]=1;
for(int j=1;j<i;j++)
stir2[i][j]= ( stir2[i-1][j-1] + ( ((j) % MOD) * (stir2[i-1][j] % MOD) )%MOD )%MOD;
}
// C[1][0] = C[1][1] = 1;
// for (int i = 2; i < N; i++){
// C[i][0] = 1;
// for (int j = 1; j < N; j++)
// C[i][j] = (C[i - 1][j] + C[i - 1][j - 1])%MOD;
// }
}
int T;
int main() {
ios_base::sync_with_stdio(false);
// freopen("data.txt","r",stdin);
init();
int n;
cin >> T;
while(T--)
{
cin >> n;
ll re = 0;
//ans = stir1[n-1][f+b-2] * C[f+b-2][f-1];
for(int i=1;i<=n;i++)
{
re += ((stir2[n][i]%MOD)*(fac[i]%MOD))%MOD;
re %= MOD;
}
cout<<re<<endl;
}
return 0;
}