Description
One day,when I was dreaming,god went into my dream,she was pretty cute,just like /^_^\...
I really wanted to talked to her,but my English was so poor and she was not a national god but a foreign one...After thirty minutes,she flew away...but story was not finished here,she had left a letter for me!!!What puzzled me so much is the letter was encoded.I had thought for many days,but still can't get it. Now I turn to you for help,with some limited prompts,can you help me to decode the whole letter?
Prompts:
GDJIJ,EL SSJT UT YWOSQNIVZMI. -> HELLO,MY NAME IS LINDAINVERS.
CN WLP JRVMFGQ BVR,IJCFI? -> DO YOU REQUIRE AID,HUMAN?
NMAB VYNNF, FI'E VC HP IXJ ZLQZI. -> ONCE AGAIN, IT'S UP TO THE ELVES.
...
I really wanted to talked to her,but my English was so poor and she was not a national god but a foreign one...After thirty minutes,she flew away...but story was not finished here,she had left a letter for me!!!What puzzled me so much is the letter was encoded.I had thought for many days,but still can't get it. Now I turn to you for help,with some limited prompts,can you help me to decode the whole letter?
Prompts:
GDJIJ,EL SSJT UT YWOSQNIVZMI. -> HELLO,MY NAME IS LINDAINVERS.
CN WLP JRVMFGQ BVR,IJCFI? -> DO YOU REQUIRE AID,HUMAN?
NMAB VYNNF, FI'E VC HP IXJ ZLQZI. -> ONCE AGAIN, IT'S UP TO THE ELVES.
...
Input
There is multy cases,please process to EOF.
Each case is one line of string with uppercase letters and white spaces and other symbols.
Each case is one line of string with uppercase letters and white spaces and other symbols.
Output
One line of the decoded string.
Sample Input
SGC CGGJX GC BMHVQ BGU BCIHNYNBX GNPLV!
Sample Output
THE FLOWS OF MAGIC ARE WHIMSICAL TODAY!
#include <stdlib.h>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include<cstdio>
#include<iostream>
#include <map>
using namespace std;
char a[50]="ABCDEFGHIJKLMNOPQRSTUVWXYZ";
char s[1000010],b;
int i,chan,num=0;
int f[100010],x,j;
int main()
{
f[0]=1;
f[1]=1;
for(int i=2;i<=100000;i++)
f[i] = (f[i-1]%26+f[i-2]%26)%26;
while(gets(s)!=NULL)
{
num = 0;
chan=strlen(s);
for(i=0;i<chan;i++)
{
if(s[i]<'A'||s[i]>'Z')
printf("%c",s[i]);
else
{
for(j=0;j<=25;j++)
if(s[i]==a[j])
{
x=j;
break;
}
x+=f[num];
x=x%26;
printf("%c",a[x]);
num++;
}
}
printf("\n");
}
return 0;
}