Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。
不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
这让很多学生很反感。
不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ) ,分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C ( 只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B( 包括A,B) 的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ) ,分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C ( 只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B( 包括A,B) 的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
Output
对于每一次询问操作,在一行里面输出最高成绩。
Sample Input
5 6
1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
Sample Output
5 6 5 9
Hint
Huge input,the C function scanf() will work better than cin
/*************************************************************************
> File Name: B.cpp
> Author:chudongfang
> Mail:1149669942@qq.com
> Created Time: 2016年08月04日 星期四 08时17分23秒
************************************************************************/
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;
#define M 200005
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
int arr[M<<2];
void build(int l,int r,int rt)
{
if(l == r){
scanf("%d",&arr[rt]);
return;
}
int m = (l+r)>>1;
build(lson);
build(rson);
arr[rt] = max(arr[rt<<1],arr[rt<<1|1]);
}
void update(int p,int sc,int l,int r ,int rt)
{
if(l == r)
{
arr[rt] = sc;
return ;
}
int m = (l+r)>>1;
if(p<=m)
update(p,sc,lson);
else
update(p,sc,rson);
arr[rt] = max(arr[rt<<1],arr[rt<<1|1]);
}
int query(int L,int R,int l,int r ,int rt)
{
if(L<=l && r<=R)
{
return arr[rt];
}
int m = (l + r) >>1;
int ret = 0;
if(L<=m)
ret = max(ret,query(L,R,lson));
if(R>m)
ret = max(ret,query(L,R,rson));
return ret;
}
int main(int argc,char *argv[])
{
int a,b,n,m;
while(scanf("%d %d",&n,&m) == 2)
{
build(1,n,1);
char op[10];
for(int i=1;i<=m;i++)
{
scanf("%s %d %d",op,&a,&b);
if(strcmp(op,"Q") == 0)
{
printf("%d\n",query(a,b,1,n,1));
}
else if(strcmp(op,"U") == 0)
{
update(a,b,1,n,1);
}
}
}
return 0;
}