Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.
As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5 Ab3bd
Sample Output
2
巧妙利用取余实现滚动数组,此处要利用到两个数组,所以对二取余
/*************************************************************************
> File Name: 1.cpp
> Author:chudongfang
> Mail:1149669942@qq.com
> Created Time: 2016年05月23日 星期一 16时26分12秒
************************************************************************/
#include<stdio.h>
#include<string.h>
#include<math.h>
int inf=9999999;
int my_max(int x,int y) { return x>y?x:y; }
int my_min(int x,int y) { return x>y?y:x; }
using namespace std;
int dp[2][5005];
char a[5005];
int n;
int main(int argc,char *argv[])
{
int i,j;
while(scanf("%d",&n)!=EOF)
{
memset(dp,0,sizeof(dp));
memset(a,0,sizeof(a));
scanf("%s",a);
for(i=n-2;i>=0;i--)
{
for(j=i+1;j<n;j++)
{
if(a[i]==a[j])
dp[i%2][j]=dp[(i+1)%2][j-1];//此处利用了滚动数组
else
dp[i%2][j]=my_min(dp[(i+1)%2][j],dp[i%2][j-1])+1;
}
}
printf("%d\n",dp[0][n-1]);
}
return 0;
}