Minimum Inversion Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19106 Accepted Submission(s): 11520
Problem Description
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)
…
an, a1, a2, …, an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16
分析
先求出初始逆序数ret, 之后每次操作逆序数的变化值δ=n-1-2*t.
t为比a[i]小的数,n-1-t 为比t大的数,所以逆序数为n-1-2*t;而t刚好等于a[i],
比如7,比7小的数的个数为7。
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=5555;
int sum[maxn<<2];
void push_up(int rt){
sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt){
sum[rt]=0;
if(l==r){
return;
}
int m=(l+r)>>1;
build(lson);
build(rson);
}
void update(int p,int l,int r,int rt){
if(l == r){
sum[rt]++;
return;
}
int m=(l+r)>>1;
if(p <= m) update(p,lson);
else update(p,rson);
push_up(rt);
}
int query(int L,int R,int l,int r,int rt){
if(L<=l &&r<=R){
return sum[rt];
}
int m=(l+r)>>1;
int ret=0;
if(L <=m) ret+=query(L,R,lson);
if(R> m) ret+=query(L,R,rson);
return ret;
}
int a[maxn];
int main(){
int n;
while(~scanf("%d",&n)){
build(0,n-1,1); //建立空树
int ret=0;
for(int i=0 ; i<n; i++){
scanf("%d",&a[i]);
ret += query(a[i],n-1,0,n-1,1); //查询当前逆序数
update(a[i],0,n-1,1); // 插入一个点
}
int ans=ret;
for(int i=0;i<n;i++){
ret +=n-1-a[i]-a[i];
ans=min(ans,ret);
}
printf("%d\n",ans) ;
}
return 0;
}
体会
裸的线段树题应该比较少,多半是线段树结合其他知识出题.线段树根据题意push_up操作和build,update,query等会有略微改变.
参考资料
这个详细讲了建树的过程
http://wenku.baidu.com/view/6e02b7492e3f5727a5e9623f.html
这个详细讲了建树后变换的操作
http://blog.csdn.net/ACdreamers/article/details/8577553