http://poj.org/problem?id=1426
Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28996 Accepted: 12023 Special Judge
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
分析
入队
ll t=q.front();
q.push(10*t);
q.push(10*t+1);
/*************************************************************************
* > File Name: poj1426.cpp
* > Author:LaPucelle
* > Mail:
* > Created Time: 2017年01月21日 星期六 22时53分25秒
* ************************************************************************/
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<climits>
#include<string>
#include<cstring>
#include<vector>
#include<set>
#include<list>
#include<map>
#include<queue>
#define rep(i,a,b) for(int i=(a);i<=(b);(i++))
#define inf 0x3f3f3f
#define ll long long
#define pi acos(-1)
int dire[4][2]={ {0,1},{1,0},{0,-1},{-1,0} };
int dire2[8][2]={{-1,-1},{-1,0},{-1,1},{ 0,-1 },{ 0,1 },{ 1,-1 },{ 1,0 },{ 1,1 }};
int dire3[6][3]={ {0,0,1},{0,1,0},{1,0,0},{0,0,-1},{0,-1,0},{-1,0,0} };
using namespace std;
void bfs(int n){
queue<ll>q;
q.push(1);
while(!q.empty()){
ll t=q.front();q.pop();
if(t%n==0){
cout<<t<<endl;
return;
}
q.push(t*10);
q.push(t*10+1);
}
}
int main()
{
std::ios::sync_with_stdio(false);
//freopen("in.txt","r",stdin);
int n;
while(cin>>n&&n){
bfs(n);
}
return 0;
}