The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
题意
a,b,c,d四个数组,从每一个数组中挑一个形成一个组合,求最多有多少个组合数为0.
#include<iostream>
#include<algorithm>
using namespace std;
#define N 4002
int a[N],b[N],c[N],d[N],e[N*N],f[N*N];
int main(){
std::ios_base::sync_with_stdio(false);
int t,i,j,q=0;
cin>>t;
for(i=0;i<t;i++)
cin>>a[i]>>b[i]>>c[i]>>d[i];
for(i=0;i<t;i++)
for(j=0;j<t;j++)
e[i*t+j]=a[i]+b[j];
for(i=0;i<t;i++)
for(j=0;j<t;j++)
f[i*t+j]=c[i]+d[j];
sort(e,e+t*t);
sort(f,f+t*t);
//把f数组中的数在e数组中查找,upper_bound-lower_bound返回值为1,表示能找到
for(i=0;i<t*t;i++)
q+=upper_bound(e,e+t*t,-f[i])-lower_bound(e,e+t*t,-f[i]);
cout<<q;
}