Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.
魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.
Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块……),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)
特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
Sample Input
1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0
Sample Output
11
思路
剪枝特麻烦..没剪好容易TLE.推荐bfs??
练bfs去.说多是泪.
/*************************************************************************
> File Name: hdu1253.cpp
> Author:ukiy
> Mail:
> Created Time: 2016年12月03日 星期六 17时37分14秒
************************************************************************/
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<climits>
#include<string>
#include<cstring>
#include<vector>
#include<set>
#include<list>
#include<map>
int dire[4][2]={ {0,1},{1,0},{0,-1},{-1,0} };
int dire2[8][2]={{-1,-1},{-1,0},{-1,1},{ 0,-1},{ 0,1},{ 1,-1},{ 1,0},{ 1,1}};
int dire3[6][3]={ {0,0,1},{0,1,0},{1,0,0},{0,0,-1},{0,-1,0},{-1,0,0} };
#define rep(i,a,b) for(int i=(a);i<=(b);(i++))
#define inf 0x3f3f3f
#define ll long long
#define pi acos(-1)
using namespace std;
#define maxn 55
int a,b,c,t,tot;
int chess[maxn][maxn][maxn];
int book[maxn][maxn][maxn];
void dfs(int x,int y,int z,int t,int step){
/*
if(x<1||x>a||y<1||y>b||z<1||z>c) return;
if ((a+b+c-x-y-z) > t) return ;
if(chess[x][y][z]==1)return;
if(step>tot|| t<0) return;
if(f[x][y][z]<=step&&g[x][y][z]>=t) return;
if(x==a&&y==b&&z==c){
tot=tot>step?step:tot;
return;
}
f[x][y][z]=step;
g[x][y][z]=t;
rep(i,0,5){
// chess[x][y][z]=1;
int px=x+dire3[i][0];
int py=y+dire3[i][1];
int pz=z+dire3[i][2];
dfs(px,py,pz,t-1,step+1);
// chess[x][y][z]=0;
}
*/
if ((a+b+c-x-y-z) > t) return ;
if(step>tot|| t<0) return;
if(x==a&&y==b&&z==c){
tot=step;
return;
}
rep(i,0,5){
int px=x+dire3[i][0];
int py=y+dire3[i][1];
int pz=z+dire3[i][2];
if(px>=1&&px<=a&&py>=1&&py<=b&&pz>=1&&pz<=c&&(book[px][py][pz]==0||step<book[px][py][pz])&&chess[px][py][pz]!=1){
book[px][py][pz]=step;
chess[px][py][pz]=1;
dfs(px,py,pz,t-1,step+1);
chess[px][py][pz]=0;
}
}
return;
}
int main()
{
//std::ios::sync_with_stdio(false);
#ifndef OnlineJudge
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
#endif
int T;
//cin>>T;
scanf("%d",&T);
while(T--){
//cin>>a>>b>>c>>t;
scanf("%d %d %d %d",&a,&b,&c,&t);
memset(book,0,sizeof(book));
rep(i,1,a){
rep(j,1,b){
rep(k,1,c){
//cin>>chess[i][j][k];
scanf("%d",&chess[i][j][k]);
}
}
}
tot=inf;
dfs(1,1,1,t,0);
if(tot==inf)
printf("-1\n");
else
printf("%d\n",tot);
}
return 0;
}