题目描述
求最长相同序列,非连续,abc与ac 最长相同序列为2
相关问题,
戳:
思路:
dp[i][j] 表示:a串中前i个元素 与 b中前j个元素中最长相同序列长度
分两种情况:
1) a[i] == b[j] 则 dp[i][j] = dp[i-1][j-1]+1 它坐上方+1
2) a[i] != b[j] 则 dp[i][j] = max( dp[i-1][j], dp[i][j-1]) 它正上方和正左方最大的
Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
/******************************
> File Name: poj_1458.cpp
> Author: dulun
> Mail: dulun@xiyoulinux.org
> Created Time: 2016年04月19日 星期二 16时48分16秒
*************************/
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define LL long long
using namespace std;
const int N = 666;
char a[N];
char b[N];
int dp[N][N];
int main()
{
while(~scanf("%s%s", a+1, b+1))
{
int ans = 0;
int len_a = strlen(a+1);
int len_b = strlen(b+1);
memset(dp, 0, sizeof(dp));
for(int i = 1; i <= len_a; i++)
{
for(int j = 1; j <= len_b; j++)
{
if(a[i] != b[j] )
{
dp[i][j] = max(dp[i-1][j], dp[i][j-1]);
}
else{
dp[i][j] = dp[i-1][j-1]+1;
}
ans = max(ans, dp[i][j]);
}
}
printf("%d\n", ans);
}
return 0;
}