题目链接:
题目大意:
有一个字符串A,一次次的重写A,会得到一个新的字符串AAAAAAAA…..,现在将这个字符串从中切去一部分得到一个字符串B,例如有一个字符串A=”abcdefg”.,复制几次之后得到abcdefgabcdefgabcdefgabcdefg….,现在切去中间红色的部分,得到字符串B,现在只给出字符串B,求出字符串A的长度
思路:
kmp求最小循环节 = len - nxt[len-1] 或 =len- nxt[len] 根据具体next数组含义而定。
F - The Minimum Length
Time Limit:1000MS Memory Limit:131072KB 64bit IO Format:%lld &
%llu Submit Status Practice HUST 1010
Description
There is a string A. The length of A is less than 1,000,000. I rewrite
it again and again. Then I got a new string: AAAAAA…… Now I cut it
from two different position and get a new string B. Then, give you the
string B, can you tell me the length of the shortest possible string
A. For example, A=”abcdefg”. I got abcd efgabcdefgabcdefgabcdefg….
Then I cut the red part: efgabcdefgabcde as string B. From B, you
should find out the shortest A.
Input
Multiply Test Cases. For each line there is a string B which contains
only lowercase and uppercase charactors. The length of B is no more
than 1,000,000.
Output
For each line, output an integer, as described above.
Sample Input
bcabcab
efgabcdefgabcde
Sample Output
3
7
/*************************************************************************
> File Name: hust_1010.cpp
> Author: dulun
> Mail: dulun@xiyoulinux.org
> Created Time: 2016年03月15日 星期二 21时02分30秒
************************************************************************/
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define LL long long
using namespace std;
const int N = 50086;
int nxt[1000006];
char a[1000006];
void getnxt(int m)
{
int k = 0;
for(int i = 1; i < m; i++)
{
while(k && a[i] != a[k]) k = nxt[k-1];
if(a[i] == a[k]) k++;
nxt[i] = k;
}
}
int main()
{
while(~scanf("%s", a))
{
memset(nxt, 0, sizeof(nxt));
int m = strlen(a);
getnxt(m);
cout<<m-nxt[strlen(a)-1]<<endl;
memset(a, 0, sizeof(a));
}
return 0;
}