Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 41544 | Accepted: 18040 |
Description
Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).
Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di
Output
* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints
Sample Input
4 6 1 4 2 6 3 12 2 7
Sample Output
23
01背包 dp[i][j] = max{dp[i-1][j],dp[i-1][j-w[i]]+v[i]}
#include <iostram>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <string>
#include <algorithm>
#include <vector>
#include <stack>
#include <queue>
#include <map>
#include <set>
using namespace std;
const int maxn = 10001;
int dp[maxn];
int w[maxn];
int v[maxn];
int main() {
int n;
int m;
while(cin >> n >> m) {
for(int i = 1;i <= n;i++) {
cin >> w[i] >> v[i];
}
memset(dp,0,sizeof(dp));
for(int i = 1;i <= n;i++) {
for(int j = m;j >= w[i];j--) {
dp[j] = max(dp[j],dp[j-w[i]]+v[i]);
}
}
cout << dp[m] << endl;
}
return 0;
}