Find The Multiple
Time Limit: 1000MS | Memory Limit: 10000K | |||
Total Submissions: 33059 | Accepted: 13834 | Special Judge |
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2 6 19 0
Sample Output
10 100100100100100100 111111111111111111
题意:只由0和1组成的十进制数,是否含有一个数整除所给的数
dfs回溯去查找太浪费时间,而且递归的终止条件很难去找,不如bfs搜索
#include <iostream>
#include <stack>
#include <queue>
#include <map>
using namespace std;
typedef long long ll;
queue <ll>q;
ll a;
void bfs() {
ll t = 1;
q.push(t);//从1开始找
while(!q.empty()) {
ll front = q.front();
if(front % a == 0) {//这里为了判断a为1
cout << front << endl;
return;
}
q.pop();//栈顶元素
for(int i = 0;i < 2;i++) {
ll x = front * 10 + i;
if(x % a == 0) {
cout << x << endl;
return;
}
q.push(x);//将接下来两个入队列
}
}
}
int main(int argc, char *argv[]) {
while(cin >> a && a) {
while(!q.empty()) {
q.pop();
}//清空队列,防止不同步相互影响
bfs();
}
return 0;
}