A == B ?
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 105458 Accepted Submission(s): 16791
Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
Input
each test case contains two numbers A and B.
Output
for each case, if A is equal to B, you should print "YES", or print "NO".
Sample Input
1 2 2 2 3 3 4 3
Sample Output
NO YES YES NO
对字符串进行处理,不直接进行比较
AC代码
#include<stdio.h>
#include<string.h>
char *haha(char *s);
char *haha(char *s){
while(*s == '0')
s++; //去除前导0
if(strchr(s,'.') != 0){
int len = strlen(s);
char *p = s + len- 1; //指针指向字符串末尾
while(*p == '0')
*(p--) = 0; //去除后导0
if(*p == '.')
*p = 0; //出现1.时把.去掉
}
return s;
}
int main(void){
char a[10000];
char b[10000];
while(scanf("%s%s",a,b) != EOF){
if(strcmp(haha(a),haha(b)) == 0){
puts("YES");
}
else
puts("NO");
}
return 0;
}