Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.
Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.
Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N
- Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input 5 5 1 2 20 2 3 30 3 4 20 4 5 20 1 5 100 Sample Output 90 Hint INPUT DETAILS: There are five landmarks. OUTPUT DETAILS: Bessie can get home by following trails 4, 3, 2, and 1.
题目大意:一共有N个节点和T条边组成的有向图,现在求源点到节点N的最短路径。
思路:Dijkstra的模板题
#include<algorithm>
#include<iostream>
#include<stdlib.h>
#include<cstring>
#include<cstdio>
#include<cstdio>
#include<cmath>
#include<queue>
using namespace std;
const int MAX = 1005;
const int INF = 0x3f3f3f3f;
struct A{
int arcs[MAX][MAX];//权值-->路径长度
int arcnum; //边的数目
int vexnum; //顶点的数目
}G;
bool visit[MAX]; //顶点的访问情况
int dis[MAX]; //出发点到其余点的最短距离
int v;
//单源最短路Dijkstra算法
//求start到end的最短路长度
int Dijkstra(int start,int end){
for(int i=1 ; i<=G.vexnum ; i++){
dis[i] = G.arcs[start][i];
visit[i] = false;
}
visit[start] = true;
//再依次添加n-1个点,更新最短路
for(int i=1 ; i<=G.vexnum-1 ; i++){
int m = INF;
for(int j=1 ; j<=G.vexnum ; j++){
//找到距离最小的
if(!visit[j] && dis[j]<m){
m = dis[j];
v = j;
}
}
//找到最短距离的点
visit[v] = true;
for(int j=1 ; j<=G.vexnum ; j++){
//更新起始点到未访问点的最短距离
dis[j] = min(dis[j],dis[v]+G.arcs[v][j]);
}
}
return dis[end];
}
int main(void){
while(cin>>G.arcnum>>G.vexnum){
//初始化图
for(int i=1 ; i<=G.vexnum ; i++){
for(int j=1 ; j<=G.vexnum ; j++){
G.arcs[i][j] = (i==j)?0:INF;
}
}
//输入权值(路径长度)
for(int i=1 ; i<=G.arcnum ; i++){
int x,y,w;
cin>>x>>y>>w;
//有重边
G.arcs[x][y] = G.arcs[y][x] =min(G.arcs[x][y],w);
}
cout<<Dijkstra(G.vexnum,1)<<endl;
}
return 0;
}