Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company’s history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.
Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan – i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)
where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.
Input
The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
Output
For each test case, your program should output the text “The highest possible quality is 1/Q.”, where 1/Q is the quality of the best derivation plan.
Sample Input
4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0
Sample Output
The highest possible quality is 1/3.
题目大意:给你n个字符串。每个字符串长度为7。他们之间同一个位置字母可能不相同,然后一个字符串只能由另一个派生出来。派生的代价就是他们字符不同的个数。求最小的总代价。
思路:prim
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAX = 2005;
const int INF = 0x3f3f3f3f;
//最小生成树prim算法
struct A{
int arcs[MAX][MAX];//权值-->字符不同的个数
int arcnum; //边的数目
bool visit[MAX]; //顶点的访问情况
int vexnum; //顶点的数目
char vex[MAX][10]; //定点的信息
}G;
int d[MAX];//选中集与未选中集的距离
int prim(void){
int min,v,ans=0;
for(int i=0 ; i<G.vexnum ; i++){
d[i] = G.arcs[0][i];
G.visit[i] = false;//每个点未访问
}
//起始点加入选中集
G.visit[0]=true;
for(int i=0 ; i<G.vexnum-1 ; i++){//选n-1个定点
//找出一个最短距离的点
min=INF;
for(int j=0 ; j<G.vexnum ; j++){
if(!G.visit[j] && d[j]<min){
v=j;
min = d[j];
}
}
//已访问
G.visit[v]=true;
ans += min;
//更新选中点集与未选中点集的距离
for(int j=0 ; j<G.vexnum ; j++){
if(!G.visit[j] && G.arcs[v][j]<d[j]){
d[j]= G.arcs[v][j];
}
}
}
return ans;
}
int main(void){
while(cin>>G.vexnum,G.vexnum){
//初始化图
for(int i=0 ; i<G.vexnum ; i++){
for(int j=0 ; j<G.vexnum ; j++){
G.arcs[i][j] = (i==j)?0:INF;
}
}
//输入顶点信息
for(int i=0 ; i<G.vexnum ; i++){
cin>>G.vex[i];
}
//赋权值
for(int i=0 ; i<G.vexnum ; i++){
for(int j=0 ; j<i ; j++){
int count=0;
for(int k=0 ; k<7 ; k++){
if(G.vex[i][k] != G.vex[j][k]){
count++;
}
}
G.arcs[i][j] = G.arcs[j][i] = count;
}
}
cout<<"The highest possible quality is 1/"<<prim()<<"."<<endl;
}
return 0;
}