FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.
FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.
Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
Input
There are several test cases. Each test case consists of
a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1
Sample Output
37
题意:老鼠初始时在nXn的矩阵的(0.0),每次最多向一个方向移动k格,每次移动过去的那个格子里面的数值必须比当前所在格子里面的大,求出路径上所有数值总和最大值
思路:忆化搜索也是制表法实现的dp,记忆化搜索=搜索+dp, 记忆化搜索的思想是,在搜索过程中,会有很多重复计算,如果我们能记录一些状态的答案,就可以减少重复搜索量
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 100;
//制表法
int n,k;
int A[MAX][MAX],dp[MAX][MAX];
int dx[]={-1,0,0,1},dy[]={0,1,-1,0};//四个个方向
bool check(int x,int y){//测试此位置是否能走(能true)
if(x<0 || y<0 || x>=n || y>=n){//越界
return false;
}
return true;
}
int DFS(int x,int y){
int ans=0;
if(dp[x][y] != -1){//已经求解过
return dp[x][y];
}
for(int i=0 ; i<4 ; i++){//方向
for(int j=1 ; j<=k ; j++){//步长
int temX = x+dx[i]*j;
int temY = y+dy[i]*j;
// 不能走 食物量小
if(!check(temX,temY) || A[temX][temY]<=A[x][y]){
continue;
}
//更新从这点出发的不同方向的最大值
ans=max(ans,DFS(temX,temY));
}
}
//记录该位置的最大值
return dp[x][y]=A[x][y]+ans;
}
int main(void){
while(cin>>n>>k,n+k+2){
for(int i=0 ; i<n ; i++){
for(int j=0 ; j<n ; j++){
cin>>A[i][j];
}
}
memset(dp,-1,sizeof(dp));
cout<<DFS(0,0)<<endl;
}
}