palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.
As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5
Ab3bd
Sample Output
2
对于回文串:其要添加的数为 n - (正串和反串的最长公共子序列)
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<queue>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
using namespace std;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const int MAXN =1e5+5;
const int MAXM = 1015;
int n;
string a,b;
int dp[2][5015];
int main()
{
// ios_base::sync_with_stdio(false);
// freopen("data.txt","r",stdin);
while(cin>>n)
{
memset(dp,0,sizeof(dp));
cin>>a;
b = a;
reverse(b.begin(), b.end());
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(a[i-1]==b[j-1])
{
dp[i%2][j] = dp[(i-1)%2][j-1] + 1;
}
else
{
dp[i%2][j] = max(dp[(i-1)%2][j],dp[i%2][j-1]);
}
}
}
cout << n - dp[n%2][n]<<endl;
}
}