Problem J: Arithmetic Sequence
Time Limit: 1 Sec Memory Limit: 128 MBSubmit: 1771 Solved: 299
[ Submit][ Status][ Web Board]
Description
Giving a number sequence A with length n, you should choosing m numbers from A(ignore the order) which can form an arithmetic sequence and make m as large as possible.
Input
There are multiple test cases. In each test case, the first line contains a positive integer n. The second line contains n integers separated by spaces, indicating the number sequence A. All the integers are positive and not more than 2000. The input will end by EOF.
Output
For each test case, output the maximum as the answer in one line.
Sample Input
5
1 3 5 7 10
8
4 2 7 11 3 1 9 5
Sample Output
4
6
HINT
#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
int n,a[2005],b[2005],i,j,t,max,len,maxx,minx;
while(scanf("%d",&n)!=EOF)
{
max=0;
maxx=0;
minx=999999;
memset(b,0,sizeof(b));
memset(a,0,sizeof(a));
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
b[a[i]]++;
if(maxx<a[i]) maxx=a[i];
if(minx>a[i]) minx=a[i];
}
for(i=0;i<n;i++)//从第一个到最后一个为开头的数列
{
if(max<b[a[i]]) max=b[a[i]];//公差为0的数列
for(j=1;j<=maxx-minx;j++)//数列长度
{
len=1;
t=a[i];
while(1)
{
t+=j;
if(b[t]==0||t>maxx) break;
len++;
}
if(max<len) max=len;
}
}
printf("%d\n",max);
}
return 0;
}