还是畅通工程
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最小的公路总长度。
Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
Sample Output
3
5
简单模板题
#include<iostream>
#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=105;
int fa[maxn];
void init(){
for(int i=0;i< maxn;i++)
fa[i]=i;
}
int Find(int x){
if(fa[x]== x) return fa[x];
else return fa[x]=Find(fa[x]);
}
void Union(int x,int y){
int fx=Find(x),fy=Find(y);
if( fx!= fy)
fa[fx] =fy;
}
typedef struct{
int st,ed,cost;
}Edge;
Edge edge[10005];
int cmp(Edge a,Edge b){
return a.cost < b.cost;
}
int main(){
ios_base::sync_with_stdio(false);
int n;
while(cin>>n,n){
int t1,t2,t3;
int m=n*(n-1)/2;
for(int i=0;i<m;i++){
cin>>t1>>t2>>t3;
edge[i].st= t1;
edge[i].ed= t2;
edge[i].cost =t3;
}
init();
sort(edge,edge+m,cmp);
int rst=n;
int tot_cost =0;
for(int i=0; i<m && rst >1 ;i++){
if(Find(edge[i].st) != Find(edge[i].ed)){
Union(edge[i].st,edge[i].ed);
rst--;
tot_cost +=edge[i].cost;
}
}
cout<<tot_cost<<endl;
}
}