Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 49498 Accepted: 21975
Description
A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8
Sample Output
4
分析
裸的LIS题,时间复杂度nlogn
AC代码
#include<cstdio>
#define N 1005
int arr[N];
int B[N];
int bisearch(int *arr,int len,int key){
int l=0,r=len-1;
while(l<=r){
int m=(l+r)>>1;
if(arr[m] == key )
return m;
else if(arr[m] < key)
l=m+1;
else
r=m-1;
}
return l;
}
int calc_LIS(int *arr,int n){
B[0]=arr[0];
int len=1;
for(int i=1;i<n;i++){
int pos=bisearch(B,len,arr[i]);
B[pos]=arr[i];
if(pos >=len)
len++;
}
return len;
}
int main(){
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",arr+i);
printf("%d\n",calc_LIS(arr,n));
return 0;
}