Stars HDU - 1541
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
题中说的很明确了,给出坐标的时候是按照上升的序列来给的(就是y从小到大,y相同时候x从小到大),就是说对于每个点level小于它的点在它之前已经给出了,所以考虑BIT维护一个树状数组,对于每个点找到在它之前给出的x小于它的点即可。需要注意的是,树状数组是不存在0节点的,在输出结果时候也要注意这个问题。
AC代码:
#include <iostream>
#include <stdio.h>
#include <memory.h>
using namespace std;
const int Max = 32100;
int c[Max];
int res[Max];
int lowbit(int i)
{
return i&(-i);
}
void add(int x,int num)
{
while(x <= Max)
{
c[x] += num;
x += lowbit(x);
}
return ;
}
int sum(int x)
{
int sum = 0;
while(x)
{
sum += c[x];
x -= lowbit(x);
}
return sum;
}
int main()
{
int n;
while(scanf("%d",&n) != EOF)
{
memset(res,0,sizeof(res));
memset(c,0,sizeof(c));
int i ;
for(i = 0;i<n;i++)
{
int x,y;
scanf("%d %d",&x,&y);
add(x+1,1); //因为树状数组不存在0节点,所以x要加1
int before_sum = sum(x+1);
res[before_sum]++;
}
for(i = 1;i<=n;i++)//从1开始输出因为是从1节点开始的
{
printf("%d\n",res[i]);
}
}
//std::cout << "Hello world" << std::endl;
return 0;
}~~~