Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.
The input is terminated with three 0’s. This test case is not to be processed.
Output
For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.
Sample Input
4 4 5
S.X.
..X.
..XD
….
3 4 5
S.X.
..X.
…D
0 0 0
Sample Output
NO
YES
思路
剪枝1
abs(dx-sx)+abs(dy-sy) 与 t的奇偶性必须一致 且 大小<=t
int len=abs(d[0]-s[0])+abs(d[1]-s[1]);
if((len&1)!=(t&1)||len>t){
printf("NO\n");
continue;
}
剪枝2
找到了就不必再找.
if(p>=1&&p<=n&&q>=1&&q<=m&&book[p][q]==0&&chess[p][q]!='X'){
book[x][y]=1;
dfs(step+1,p,q);
book[x][y]=0;
if(now)
return;
}
最后注意:开始遍历的起点不一定是 (1,1).
/*************************************************************************
> File Name: hdu1010.cpp
> Author:gens_ukiy
> Mail:
> Created Time: 2016年12月01日 星期四 07时28分58秒
************************************************************************/
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<climits>
#include<string>
#include<cstring>
#include<vector>
#include<set>
#include<list>
#include<map>
using namespace std;
#define rep(i,a,b) for(int i=(a);i<=(b);(i++))
#define inf 0x3f3f3f
#define ll long long
#define pi acos(-1)
int dire[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
char chess[8][8];
int book[8][8];
int n,m,t,s[2],d[2],now;
void dfs(int step,int x,int y){
if(step==t){
if(chess[x][y]=='D')
now=1;
return;
}
if(book[x][y]==0){
rep(i,0,3){
int p=x+dire[i][0];
int q=y+dire[i][1];
if(p>=1&&p<=n&&q>=1&&q<=m&&book[p][q]==0&&chess[p][q]!='X'){
book[x][y]=1;
dfs(step+1,p,q);
book[x][y]=0;
if(now)
return;
}
}
return;
}
return;
}
int main()
{
while(cin>>n>>m>>t){
if(n==0&&m==0&&t==0) break;
now=0;
memset(book,0,sizeof(book));
rep(i,1,n)
rep(j,1,m){
cin>>chess[i][j];
if(chess[i][j]=='S')
s[0]=i,s[1]=j;
if(chess[i][j]=='D')
d[0]=i,d[1]=j;
}
int len=abs(d[0]-s[0])+abs(d[1]-s[1]);
if((len&1)!=(t&1)||len>t){
printf("NO\n");
continue;
}
dfs(0,s[0],s[1]);
if(now)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}