题目链接:
描述:
给出一字符串,求所有公共前后缀长度,从小到大输出,显然字符串长度也为一个公共前后缀,且为最长的
Description
The little cat is so famous, that many couples tramp over hill and
dale to Byteland, and asked the little cat to give names to their
newly-born babies. They seek the name, and at the same time seek the
fame. In order to escape from such boring job, the innovative little
cat works out an easy but fantastic algorithm:Step1. Connect the father’s name and the mother’s name, to a new
string S. Step2. Find a proper prefix-suffix string of S (which is not
only the prefix, but also the suffix of S).Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’.
Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given
the string S, could you help the little cat to write a program to
calculate the length of possible prefix-suffix strings of S? (He might
thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a
single line that contains the string S described above.Restrictions: Only lowercase letters may appear in the input. 1 <=
Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5
思路:
利用next数组,abcab ……… abcab 最后一个字符的next值为以该字母结束的最长前后缀长度,再到公共缀中找,公共前后缀,必然是整个串的公共前后缀
/*************************************************************************
> File Name: poj_2752.cpp
> Author: dulun
> Mail: dulun@xiyoulinux.org
> Created Time: 2016年03月21日 星期一 12时25分35秒
************************************************************************/
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define LL long long
using namespace std;
const int N = 400009;
char a[N];
int nxt[N];
int sum[N];
void get_nxt()
{
int k = 0;
int l = strlen(a);
memset(nxt, 0, sizeof(nxt));
for(int i = 1; i < l; i++)
{
while(k && a[i] != a[k]) k = nxt[k-1];
if(a[i] == a[k]) k++;
nxt[i] = k;
}
}
int main()
{
while(scanf("%s", a) != EOF)
{
get_nxt();
int l = strlen(a);
memset(sum, 0, sizeof(sum));
int k = 0;
int m = l;
while(m)
{
sum[k++] = nxt[m-1];
m = nxt[m-1];
}
for(int i = k-2; i>=0; --i) printf("%d ", sum[i]);
printf("%d\n", l);
}
return 0;
}