B - Longest Ordered Subsequence
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Description
A numeric sequence of
ai is ordered if
a1 <
a2 < ... <
aN. Let the subsequence of the given numeric sequence (
a1,
a2, ...,
aN) be any sequence (
ai1,
ai2, ...,
aiK), where 1 <=
i1 <
i2 < ... <
iK <=
N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7 1 7 3 5 9 4 8
Sample Output
4
最长升序列,简单模板
/*************************************************************************
> File Name: 1.cpp
> Author:chudongfang
> Mail:1149669942@qq.com
> Created Time: 2016年05月23日 星期一 16时26分12秒
************************************************************************/
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
int my_max(int x,int y) { return x>y?x:y; }
int my_min(int x,int y) { return x>y?y:x; }
using namespace std;
int n,a[1005],dp[1005];
int main(int argc,char *argv[])
{
int i,j,max;
while(scanf("%d",&n)!=EOF)
{
max=0;
memset(a,0,sizeof(a));
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
for(i=1;i<=n;i++)
{
dp[i]=1;
for(j=1;j<i;j++)
{
if(a[i]>a[j])
{
dp[i]=my_max(dp[i],dp[j]+1);
}
}
max=my_max(max,dp[i]);
}
printf("%d\n",max);
}
return 0;
}