Description
7 3 8 8 1 0 2 7 4 4 4 5 2 6 5 (Figure 1)
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
Sample Output
30
简单一维DP,
/*************************************************************************
> File Name: practice.cpp
> Author:chudongfang
> Mail:1149669942@qq.com
> Created Time: 2016年05月23日 星期一 16时06分57秒
************************************************************************/
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
int my_max(int x,int y) { return x>y?x:y; }
int my_min(int x,int y) { return x>y?y:x; }
using namespace std;
int a[105][105];
int dp[105][105];
int n;
int main(int argc,char *argv[])
{
int i,j;
int m;
while(scanf("%d",&m)!=EOF)
{
memset(dp,0,sizeof(dp));
for(i=1;i<=m;i++)
{
for(j=1;j<=i;j++)
{
scanf("%d",&a[i][j]);
}
}
for(i=m;i>=1;i--)
{
for(j=1;j<=i;j++)
{
dp[i][j]=my_max(dp[i+1][j],dp[i+1][j+1])+a[i][j];
}
}
printf("%d\n",dp[1][1]);
}
return 0;
}