Technicians in a pathology lab analyze digitized images of slides.
Objects on a slide are selected for analysis by a mouse click on the
object. The perimeter of the boundary of an object is one useful
measure. Your task is to determine this perimeter for selected
objects.The digitized slides will be represented by a rectangular grid of
periods, ‘.’, indicating empty space, and the capital letter ‘X’,
indicating part of an object. Simple examples areXX Grid 1 .XXX Grid 2
XX .XXX
.XXX ...X ..X. X...
An X in a grid square indicates that the entire grid square, including
its boundaries, lies in some object. The X in the center of the grid
below is adjacent to the X in any of the 8 positions around it. The
grid squares for any two adjacent X’s overlap on an edge or corner, so
they are connected.XXX
XXX Central X and adjacent X’s
XXX
An object consists of the grid squares of all X’s that can be linked
to one another through a sequence of adjacent X’s. In Grid 1, the
whole grid is filled by one object. In Grid 2 there are two objects.
One object contains only the lower left grid square. The remaining X’s
belong to the other object.The technician will always click on an X, selecting the object
containing that X. The coordinates of the click are recorded. Rows and
columns are numbered starting from 1 in the upper left hand corner.
The technician could select the object in Grid 1 by clicking on row 2
and column 2. The larger object in Grid 2 could be selected by
clicking on row 2, column 3. The click could not be on row 4, column
3.One useful statistic is the perimeter of the object. Assume each X
corresponds to a square one unit on each side. Hence the object in
Grid 1 has perimeter 8 (2 on each of four sides). The perimeter for
the larger object in Grid 2 is illustrated in the figure at the left.
The length is 18.Objects will not contain any totally enclosed holes, so the leftmost
grid patterns shown below could NOT appear. The variations on the
right could appear:Impossible Possible
XXXX XXXX XXXX XXXX
X..X XXXX X… X…
XX.X XXXX XX.X XX.X
XXXX XXXX XXXX XX.X
….. ….. ….. …..
..X.. ..X.. ..X.. ..X..
.X.X. .XXX. .X… …..
..X.. ..X.. ..X.. ..X..
….. ….. ….. …..
Input
The input will contain one or more grids. Each grid is preceded by a
line containing the number of rows and columns in the grid and the row
and column of the mouse click. All numbers are in the range 1-20. The
rows of the grid follow, starting on the next line, consisting of ‘.’
and ‘X’ characters.The end of the input is indicated by a line containing four zeros. The
numbers on any one line are separated by blanks. The grid rows contain
no blanks.
Output
For each grid in the input, the output contains a single line with the
perimeter of the specified object.
Sample Input
2 2 2 2
XX
XX
6 4 2 3
.XXX
.XXX
.XXX
…X
..X.
X…
5 6 1 3
.XXXX.
X….X
..XX.X
.X…X
..XXX.
7 7 2 6
XXXXXXX
XX…XX
X..X..X
X..X…
X..X..X
X…..X
XXXXXXX
7 7 4 4
XXXXXXX
XX…XX
X..X..X
X..X…
X..X..X
X…..X
XXXXXXX
<0 0 0 0
Sample Output
8
18
40
48
8
-
-
题目大意:给定你一个点,从这个点扩散的8个方向只要能连就算一个整体,然后让你算这个整体的周长。
第一步DFS得到整体,第二步分析规律求周长。因为整体由小正方块组成,在平台四角的方块会有两条边是永远暴露的,除四角以外的边框部分的方块会有一条边是永远暴露的。其余的正方块的边长由他上下左右四个方向的点决定。这样将所有的小正方块的周长累加起来就是这个整体的周长。
#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;
int per = 0;
char rec[20+1][20+1];
int visit[21][21];
int dir[8][2] = {{ 0, 1}, {0, -1}, {1, 0}, {-1, 0}, {1, 1}, {1, -1}, {-1, 1}, {-1, -1} };
int row, col;
void dfs(int x, int y){
if(visit[x][y] || rec[x][y] != 'X'){
return;
}
visit[x][y] = 1;
if(x == row){
per++;
}
if(y == col){
per++;
}
if(y == 1){
per++;
}
if(x == 1){
per++;
}
for(int j = 0; j < 4; j++){
if(rec[x + dir[j][0]][y + dir[j][1]] == '.'){
per++;
}
}
for(int i = 0; i < 8; i++){
int xx = x + dir[i][0];
int yy = y + dir[i][1];
if(xx <= row && xx > 0 && yy <= col && yy > 0){
dfs(xx, yy);
}
}
}
int main(){
int x, y;
while(cin >> row >> col >> x >> y && row && col && x && y){
memset(rec, 0, sizeof(rec));
memset(visit, 0, sizeof(visit));
for(int i = 1; i <= row; i++){
for(int j = 1; j <= col; j++){
cin >> rec[i][j];
}
}
dfs(x, y);
cout << per << endl;
per = 0;
}
}