题目链接:
Description
Farmer John has been elected mayor of his town! One of his campaign
promises was to bring internet connectivity to all farms in the area.
He needs your help, of course. Farmer John ordered a high speed
connection for his farm and is going to share his connectivity with
the other farmers. To minimize cost, he wants to lay the minimum
amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms,
you must find the minimum amount of fiber needed to connect them all
together. Each farm must connect to some other farm such that a packet
can flow from any one farm to any other farm. The distance between any
two farms will not exceed 100,000.
Input
The input includes several cases. For each case, the first line
contains the number of farms, N (3 <= N <= 100). The following lines
contain the N x N conectivity matrix, where each element shows the
distance from on farm to another. Logically, they are N lines of N
space-separated integers. Physically, they are limited in length to 80
characters, so some lines continue onto others. Of course, the
diagonal will be 0, since the distance from farm i to itself is not
interesting for this problem.
Output
For each case, output a single integer length that is the sum of the
minimum length of fiber required to connect the entire set of farms.
Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
Sample Output
28
思路:
给出图的矩阵,求最小生成树,鄙人采用一把prim算法
/********************************
> Author: dulun
> Mail: dulun@xiyoulinux.org
> Created Time: 2016年04月03日 星期日 15时43分42秒
*****************************************/
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define LL long long
using namespace std;
const int inf = 1 << 30;
const int N = 586;
int n;
int d[N];
int a[N][N];
bool v[N] = {0};
int prim()
{
int ans = 0, min = inf, k = 0;
v[0] = 1;
for(int num = 1; num < n; num++, ans+= min, min = inf, v[k] = 1)
{
for(int y = 0; y < n; y++)
if(!v[y] && d[y] > a[y][k]) d[y] = a[y][k];
for(int y = 0; y < n; y++)
if(!v[y] && d[y] < min) min = d[k=y];
}
return ans;
}
void init()
{
memset(v, 0, sizeof(v));
memset(a, 0, sizeof(a));
memset(d, 0x3f3f3f, sizeof(d));
}
int main()
{
while(~scanf("%d", &n))
{
init();
for(int i = 0; i < n; i++)
for(int j = 0; j < n; j++) scanf("%d", &a[i][j]);
printf("%d\n", prim());
}
return 0;
}